티스토리 뷰

최근에 책을 구매하시는 분들중에 같은 고민을 하시는 분들이 계실 것 같아서, 포스팅을 하게 됐습니다.


얼마전 독자분 중에 한 분이 책을 보고 하둡을 설치하시는데,

책에 있는 버전과 실제 아파치 다운로드 사이트(http://apache.mirror.cdnetworks.com/hadoop/common/)에 있는 버전이 맞지 않아서 버전을 찾느라 고생하셨다는 이야기를 들었습니다.


제가 책을 쓸 시점의 하둡의 stable 버전이 1.0.4라서, 책의 모든 실습이 1.0.4로 진행이 됐는데요.


오늘 확인해보니 stable 버전이 1.1.2로 올라왔더군요.. ㅠㅠ

(참고 사이트: http://hadoop.apache.org/releases.html#News)


책에 있는 1.0.4가 없더라도 당황하지 마시고,

stable 버전인 1.1.2를 설치하셔서 스터디를 진행하시면 됩니다.


혹시나 1.1.2에서 소스 코드를 실행했을 때, 컴파일이 안된다거나, API가 삭제된 게 있다면

언제든지 연락을 주시고요. ㅎㅎ


그리고 하둡 에코 시스템을 설치하실 때는 항상 stable 버전을 설치하시기를 추천드립니다.

개인적인 스터디 차원에서 최신 버전을 사용하시는 것은 상관이 없으나,

업무에 적용하실 때는 반드시 stable 버전을 쓰시기 바랍니다. ^^;;

댓글
댓글쓰기 폼